Forum

  • If you are new to these Forums, please take a moment to register using the fields above.

Announcement

Announcement Module
Collapse
No announcement yet.

DYMO LM150 labeller

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • DYMO LM150 labeller

    I bought a DYMO LM150 labeller about six months ago.

    http://global.dymo.com/enAU/Products...NAGER_150.html

    It worked fine for a few months and now it is missing bits of the characters when it prints. I have tried cleaning the print head with the included head cleaner but that doesn't help much.

    It was a pretty cheap labeller -- should I just get something else or go for a Brother? Has anyone had experience with the DYMO LM150 labeller ?

    Thanks - Michael

  • #2
    DYMO LM150 Works for me!

    I've had that labeller for 2 years now with no problems at all.
    Maybe you got a dud!
    If it's only 6 months old, perhaps it would still be covered by the warranty.

    Comment


    • #3
      Try new batteries

      While I do not use this printer, many electronic items work best with fresh batteries. So you may want to look at these, even if the low battery indicator is not on.

      Additionally, check the tape cassette. Three things to look for:
      [1] tape tension
      [2] cassette is seated correctly
      [3] how much tape is left.

      In many cases a new cassette resolves the issue.

      If the above does not resolve the problem contact the manufacture and have the machine serviced or at least seek a refund.

      Comment


      • #4
        My LM 150 is very happy after 14 months of GTDing. I'm on my third tape and second set of batteries. I'd agree with ReBuild - a new cassette is a good NA!

        Ruth

        Comment


        • #5
          Thanks everyone for the suggestions. I had tried the new battery but I hadn't thought of a new cassette --- I'll give that a go.

          Regards - Michael

          Comment


          • #6
            Batteries? We don't need no stinkin' batteries!

            My Dymo LM150 came with an AC power supply.

            Even if it didn't come with it you can purchase an adaptor that will work with it.

            Well worth having it....lose those batteries.

            If your labeller plugs into the wall, it's far less likely to be borrowed (stolen) by a coworker, and you never have to touch those batteries held neatly together with a rubber band in the second drawer of your desk.

            Comment


            • #7
              OK the new tape seems to have fixed the problem. Bit of a pain as there was a lot of tape left and they cost about half the price of the labeller itself. Does anyone know if the tapes have a maximum shelf life ? The replacement one was the only one in the shop (OfficeWorks in Australia) and it looked like it had been there awhile.

              Thanks - Michael
              Last edited by mmurray; 01-26-2007, 08:21 PM.

              Comment

              Working...
              X